PunBB Resource

Your ultimate PunBB resource!

Keywords:

    (Extended)

You are not logged in.

#1 2006-02-14 19:15:55

Mark
Moderator
From: North West England
Registered: 2005-06-06
Posts: 1165

[HOWTO] - upgrade mod to work on version 1.2.*

Lots of people have been asking for a mod to be upgraded. Well there is not really any need to ask for this. All you need to do is

1. open install_mod.php
2. find line 12
3. add the version of the forum you are using to the version array.
4. save and upload.

thats it.

your version array should then look something like this...

Code:

$punbb_versions    = array('1.2.8', '1.2.9', '1.2.10', '1.2.11', '1.2.12', '1.1.13', '1.2.14', '1.2.15', '1.2.16');

Cant find something you want? try searching
Also try the wiki

Offline

 

#2 2006-02-15 01:49:24

pogenwurst
Member
From: U.S.A.
Registered: 2005-10-30
Posts: 45

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Ah! I was going to write something like this on PunBB.org, but endlessly procrastinated. You beat me to it. smile

Anyway, nice.


Looking for a certain modification for your forum? Please take a look here before posting.

Offline

 

#3 2006-02-15 10:20:22

Mark
Moderator
From: North West England
Registered: 2005-06-06
Posts: 1165

Re: [HOWTO] - upgrade mod to work on version 1.2.*

could do with being stickyed wink

edit - wa hey, its stickyed smile

Last edited by Mark (2006-02-15 17:00:20)


Cant find something you want? try searching
Also try the wiki

Offline

 

#4 2006-02-15 21:07:59

pogenwurst
Member
From: U.S.A.
Registered: 2005-10-30
Posts: 45

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Mark wrote:

could do with being stickyed wink

edit - wa hey, its stickyed smile

Stickied on PunBB.org, too. smile


Looking for a certain modification for your forum? Please take a look here before posting.

Offline

 

#5 2006-02-15 21:32:03

Mark
Moderator
From: North West England
Registered: 2005-06-06
Posts: 1165

Re: [HOWTO] - upgrade mod to work on version 1.2.*

ty smile


Cant find something you want? try searching
Also try the wiki

Offline

 

#6 2006-10-21 21:54:17

Chad92
New member
Registered: 2006-10-21
Posts: 1

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Thanks Mark!  I just upgraded to 1.2.14, and none of the mods I wanted to install would let me, because they weren't compatible.  Not anymore!  Thanks!

Offline

 

#7 2007-02-16 23:40:00

duffry
Member
Registered: 2007-02-16
Posts: 33

Re: [HOWTO] - upgrade mod to work on version 1.2.*

I don't mean to be rude but isn't this a bodge?

While you're right, it does prevent the installation from being blocked it's not an upgrade. What this is doing is telling the forum that the mod will work when there's a chance that it won't.
I'm pretty sure I'm not telling you anything and most people reading this will also realise it but wouldn't the post be better titled
[HOWTO] - Force a mod to install on any version
?

Offline

 

#8 2007-02-16 23:47:04

elbekko
Moderator
From: Leuven, Belgium
Registered: 2006-01-31
Posts: 1353

Re: [HOWTO] - upgrade mod to work on version 1.2.*

It does work, when a major change comes out that will affect alot of mods, we'll put up an alert for that in the first post. No need for that now. It's a perfectly valid 'upgrade' to just add an entry to an array when you know it'll work.


FluxBB
dictionary.com on programming: The most fun you can have with your clothes on (although clothes are not mandatory).

Offline

 

#9 2007-02-18 17:09:46

duffry
Member
Registered: 2007-02-16
Posts: 33

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Doesn't that assume that no mods effect areas effected by version upgrades?

It may be an acceptable risk and I agree that in almost all cases forcing the install will get the job done but it's no guarantee that the mod will work as it hasn't been proven on that version. If it had been then I'm assuming the person testing it would amend the array in the download file to show that it had been successfully tested.

I don't want to go rounds with you guys who have far more experience with punbb than I but I don't see how it can be considered a "valid upgrade" when you surely can't know it'll work.

Am I missing something obvious here?

Offline

 

#10 2007-02-18 18:25:03

Mark
Moderator
From: North West England
Registered: 2005-06-06
Posts: 1165

Re: [HOWTO] - upgrade mod to work on version 1.2.*

well some mods have been made befor like version 1.2.14 has come out. so they couldnt test on them so they put the array up to what ever version was out then.


Cant find something you want? try searching
Also try the wiki

Offline

 

#11 2007-02-18 21:31:40

duffry
Member
Registered: 2007-02-16
Posts: 33

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Mark wrote:

well some mods have been made befor like version 1.2.14 has come out. so they couldnt test on them so they put the array up to what ever version was out then.

Exactly, so since these mods have not been tested on the later versions it is not possible to say with complete certainty that adding the installed version number to the array will be enough to make it work. All that can be said is that it will bypass the check that stops it installing if the current version number is not in that array.
It would do as much as changing the forum version number (not the installation, just the number) to one that is already in the array or by preventing the forum from performing the check altogether. Neither as as easy but both as effective at ensuring the mod will still work with the installed version of punbb; i.e. not at all.

Offline

 

#12 2007-02-19 20:15:20

duffry
Member
Registered: 2007-02-16
Posts: 33

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Offline

 

#13 2007-02-19 21:04:03

guardian34
Member
Registered: 2006-06-03
Posts: 114

Re: [HOWTO] - upgrade mod to work on version 1.2.*

duffry wrote:

Exactly, so since these mods have not been tested on the later versions it is not possible to say with complete certainty that adding the installed version number to the array will be enough to make it work.

That depends on what changes have occured. If it was tested on, say, 1.2.12, then the mod is unlikely to be affected by the security changes in 1.2.13 and 1.2.14. That said, your point is both clear and understood.

Offline

 

#14 2007-09-09 14:49:15

dilauro
Member
From: New Milford, CT
Registered: 2007-09-06
Posts: 159
Website

Re: [HOWTO] - upgrade mod to work on version 1.2.*

Mark wrote:

Lots of people have been asking for a mod to be upgraded. Well there is not really any need to ask for this. All you need to do is

1. open install_mod.php
2. find line 12
3. add the version of the forum you are using to the version array.
4. save and upload.

thats it.

your version array should then look something like this...

Code:

$punbb_versions    = array('1.2.8', '1.2.9', '1.2.10', '1.2.11', '1.2.12', '1.1.13', '1.2.14', '1.2.15');

I did that and the mod installed, now it says
Open the admin plugin and it will allow you to configure the mod.
Is thatpart of the Admin function on the tool bar or someplace else?
Sorry,I am new to this


Ron

30+ years with Big Blue  Main Frames and Personal Computers - And Still learning every day!

Offline

 

#15 2011-03-26 19:25:42

dafodil
New member
Registered: 2011-03-24
Posts: 3

Re: [HOWTO] - upgrade mod to work on version 1.2.*

I'd be suggesting that you get a decent host, by the sounds of it. Unless you've manually mangled your database, something ain't right.

Obviously, to sort that specific problem, recreate the table which is missing, (and any others which have disappeared).

Offline

 

Board footer

Based on PunBB
© Copyright 2002–2005 Rickard Andersson

© Copyright 2004–2006 Kristoffer Jansson

User contributed files are property of their respective owners.